Tapatalk can't validate user

  • when I made an account on Tapatalk for here, it won't validate my account and the email I got just said "wcf.user.register.needActivation.mail"


    I tried twice and the same thing happened

  • Go to Best Answer
  • I’ve submitted a ticket to Tapatalk since I noticed this too when I tried myself. In the meantime I’ve disable in-app registration until it can be resolved.

  • As a small update they will be looking into this shortly - will keep you updated as I hear more information!


    Note: in order for them to validate what is going on, I have turned the in-app registration on (although it WILL error out). If you get stuck on validating, send us a message in the contact us form.

    • Best Answer

    Looks like they have investigated and found nothing wrong. Ironically I also tried to reproduce this again and everything came through correctly.


    If you see this again let us know via the contact us form or by making an account this way and syncing it to Tapatalk.


    Additionally you just make sure your Tapatalk account is validated before trying to register or it will cause some odd issues that you may have been seeing.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!